2 thoughts on “C++ Reflection Part 4: Variant

  1. Lee R

    Hi Randy,

    First off, I think you’ve created a great blog here, with some really useful articles. Keep it up :)

    However, I’d like to point out that most of the code presented in this post shouldn’t even compile (and doesn’t, in GCC 4.7.2). The META_TYPE macro accesses the dependant type name ‘type’ from the class ‘RemQual’.  This should result in a compilation error when META_TYPE is used inside a template class/function. The appropriate fix depends on the desired level of portability.


    1. Randy Gaul Post author

      Hey thanks for pointing that out! I do use MS’s compiler most of the time. If I find some extra time I will come back here and cleanup for GNU. It’s really just a matter of spare time :)


Leave a Reply

Your email address will not be published. Required fields are marked *

You may use these HTML tags and attributes: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code class="" title="" data-url=""> <del datetime=""> <em> <i> <q cite=""> <strike> <strong> <pre class="" title="" data-url=""> <span class="" title="" data-url="">